WebI: Issues with WebI's PDF view such as missing navigational elements, spinning wheel, and PDF errors

Issue:
When I use the BI Launch Pad PDF view in WebI, sometimes I cannot get to the PDF page. If I do get there my settings don't stick (or some items, like report tabs, don't display). Are there tips for using the PDF view?

Environment:
The WebI PDF View behaves differently depending on the operating system or browser being used.

Cause :
The vendor, SAP, considers this normal behavior for the BI Launchpad.

Resolution:
Do not use the PDF View in WebI. If you want to view your report or save your report to PDF, export the report to Adobe Acrobat's PDF application. For Export instructions see the Report Reader Quick Guide .

In addition, any settings you change while in PDF mode will not be saved. You will have to take these steps each time you open a document.

 

Details:
When you change your Reading view from HTML View to PDF View, or if you change your Preferences to PDF View, the behavior of WebI becomes unpredictable. In some browsers:

  • The PDF view will display your report, or
  • It will try to open Adobe acrobat, which may or may not open, or
  • The window will display an error message of a blank screen.

If you decide to access your report in PDF view anyway, the refresh icon, report tabs and navigation controls are not available .

  • The Quick Prompt window (left panel question mark icon) should be used to refresh the data in the report.
  • Report tabs are contained within a single PDF View. Scroll down to see data on additional report tabs.
  • If you mouse over the top or bottom of the report, you will see the Adobe icon (last option) displayed.Adobe Icons
  • Click on the Adobe icon. You now have access to your PDF navigational controls.

Adobe Navigation

If you want to see the report tabs listed at the bottom of a report, do the following:

  • In the upper left-hand corner, select the Web Intelligence menu.
  • Click the Report Tabs option until there is no check-mark next to it.
  • Select Web Intelligence again, and click the Report Tabs option again so that there is a check-mark next to it.

The report tabs should now appear at the bottom of your report. However if you click on another tab, you no longer have access to the PDF navigators. If you click back to your original tab, those Adobe options are still not available. To get your Adobe navigation back, you have to switch to HTML design and the back to Adobe and re-click the Adobe icon.

Reminder: Any settings you change while in PDF mode will not persist. You will have to take these steps each time you open a document.

*Need help?*
If you need help, please contact the Center for DATA WebI team at https://td.usnh.edu/TDClient/Requests/ServiceDet?ID=142 or by calling the IT Service Desk at 862-4242.

Details

Article ID: 997
Created
Fri 7/19/19 5:46 PM
Modified
Wed 9/27/23 9:01 AM
Applicable Institution(s):
Keene State College (KSC)
Plymouth State University (PSU)
University of New Hampshire (UNH)
USNH System Office