Unsupported Google Chrome plugins

Summary

This article describes why a number of plugins for Google Chrome are no longer supported.

Content

A notice for anyone using Google Chrome as your browser.  What does this mean for UNH students and faculty?

What’s this all about? Google has changed its Chrome browser so that it (unfortunately) does not use some services like Java and Silverlight. Google has its own reasoning for this - read the link at the bottom for more info.

 How does this affect me?  myCourses and other UNH services use some of the plugins that Chrome has stopped supporting. Specifically, Collaborate, and some publisher content has stopped working in myCourses and video conferencing and screen recording tools have ceased to work in myCourses. Everything else will continue to work in Chrome, just not the few tools that use the unsupported plugins.

 What should I do? If you are not a Chrome user, you can ignore this message.  If you do use Google's Chrome browser, the only real solution is to use Firefox, Safari, or Internet Explorer when using any of the unsupported tools listed above. 

The technical stuff: The issue began with version 42 of Chrome.  Google disabled the NPAPI (Netscape Plugin Application Programming Interface) by default which keeps Chrome from launching the Java plugin that runs associated media and other plugins (like Silverlight). As of September 2015, Google Chrome no longer runs NPAPI at all. For more information about NPAPI plugin, please visit the Google Support site:  https://support.google.com/chrome/answer/6213033?hl=e

 

Need additional help?

Please fill out this myCourses webform with as much detail as possible.

Details

Article ID: 771
Created
Fri 7/19/19 5:35 PM
Modified
Fri 10/4/19 12:06 PM